How To Fix Error Message : In Order To Configure TCP/IP , You Must Install And Enable Network Adapter Error In Windows

22 Comments

This article applies to a different version of Windows than the one you are using.

SYMPTOMS:-
When you try to open the TCP/IP properties of your network adapter, you may receive the following error message:
Microsoft TCP/IP
In order to configure TCP/IP, you must install and enable a network adapter card.

CAUSE:-
This behavior can occur if your network adapter has been changed to another model of network adapter without first being properly uninstalled by using the Add/Remove Hardware tool in Control Panel.
OR
Often when device drivers are updated for network interface card, the mismatch between previous model of network adapter and newer one (or the newer driver) can cause a weird error which pops up when trying to access TCP/IP properties and looks something like this :



But there is a very simple fix for this and works on all versions of Windows. To remove this error.
I will show you step by step process here  :

Step 1: Right click on your desktop computer icon and go to manage


Step 2: Now Computer management dialog box will open, under that click on 
            Device manager ==>Network adapters


Step 3: Now drill down to the specific network adapter and select “Uninstall”.





Now click on OK so it will be uninstalled

Step 4:  After it’s removed, now click on  Actions ==> Scan for hardware changes.




Step 5: Now to check whether the error prompt goes or not go to start ==> Run ==> ncpa.cpl and press enter


Now you can see network connection under that right click on Ethernet (or your wirless connection where issue persisting ) and then click on Internet Protocol version 4 



Step 6: The network adapter will once again show up in installed devices list.

Now try accessing the TCP/IP properties for that adapter, the error will no longer pop-up and the IP settings can be changed as needed.



Burp suite not capturing https traffic - Burp Certificate issue

Add Comment


Step -1 

If you are using Burp Suite Professional v1.6beta and if you are not able to capture https traffic that means you are using java version 8 or latest.

In order to solve this issue you need to degrade to java below version OR uninstall the current java which you have installed and install Java 7 Installation setup .

Step-2 

Download the burp certificate as follow

==>
1. Start burp
2. Configure firefox for loopback proxy (127.0.0.1:8080)
3. type http://burp in firefox and enter ( make sure your burp's intercept should be on  )
4. Click on CA certificate, and download it.
5. In firefox Goto Options > Advanced > Certificates > View Certificates > In Authorities Tab > Import the downloaded certificate .
6. Restart the browser

==> Also refer Installing burp's Burp CA Certificate  Article.